Canonical corrigiu falhas de inicialização no Ubuntu 18.04 e 16.04 LTS!

No início deste mês, em 2 de julho, a Canonical lançou uma atualização de segurança do kernel Linux para usuários do Ubuntu 18.04 LTS (Bionic Beaver), abordando um total de seis vulnerabilidades de segurança, uma das quais introduziu uma regressão que também acabou causando falhas de inicialização, embora não tenha se limitado apenas aos processadores AMD, mas também às máquinas Intel.

Cerca de duas semanas atrás, a Canonical corrigiu essa regressão na série de sistemas operacionais Ubuntu 14.04 LTS (Trusty Tahr).

Agora, a empresa lan√ßou novas atualiza√ß√Ķes de kernel para corrigir a regress√£o, causando falhas de inicializa√ß√£o em m√°quinas de 64 bits, bem como para processadores OEM e sistemas em execu√ß√£o no Amazon Web Services (AWS). Azure, Google Cloud Platform (GCP) e outros ambientes de nuvem.

‚ÄúO USN-3695-1 CORRIGIU VULNERABILIDADES NO KERNEL DO LINUX PARA O UBUNTU 18.04 LTS. INFELIZMENTE, A CORRE√á√ÉO PARA O CVE-2018-1108 INTRODUZIU UMA REGRESS√ÉO EM QUE A ENTROPIA PRECOCE INSUFICIENTE IMPEDIA QUE OS SERVI√áOS FOSSEM INICIADOS, LEVANDO, EM ALGUMAS SITUA√á√ēES, A UMA FALHA NA INICIALIZA√á√ÉO. ESTA ATUALIZA√á√ÉO SOLUCIONA O PROBLEMA. PEDIMOS DESCULPAS PELO INCONVENIENTE.‚ÄĚ

Como a Canonical permite que usu√°rios de vers√Ķes anteriores do Ubuntu LTS utilizem o kernel Linux de vers√Ķes mais recentes do Ubuntu LTS, o patch para a referida regress√£o causando falhas de inicializa√ß√£o, tamb√©m est√° dispon√≠vel para usu√°rios do Ubuntu 16.04.4 LTS (Xenial Xerus) que possuem o kernel HWE (Hardware Enablement) do Ubuntu 18.04 LTS (Bionic Beaver) instalado por padr√£o.

Todos os usu√°rios do Ubuntu 18.04 LTS e do Ubuntu 16.04 LTS devem atualizar suas instala√ß√Ķes para as novas vers√Ķes do kernel do Linux que est√£o dispon√≠veis nos principais reposit√≥rios de software o mais r√°pido poss√≠vel e reiniciar seus computadores ap√≥s uma instala√ß√£o bem-sucedida.

Enquanto os usu√°rios do Ubuntu 18.04 LTS precisam atualizar para o linux-image 4.15.0-29.31, os usu√°rios do Ubuntu 16.04.4 LTS devem atualizar para o linux-image 4.15.0-29.31~16.04.1.